Modules do not show up and/or disappear

3.10.3. Modules do not show up and/or disappear

Figure 3-38. Administration panel: Modules.

Administration panel: Modules.



In PHP-Nuke version 7 alpha, when adding a module to the modules folder it won't show in admin/modules. When renaming a module, with FTP or similar, the module also disappears (see Modules do not show and/or disappear).

The problem is that in admin/modules/modules.php, of that version, on the line that inserts the modules in the folder modules, the number of fields is incorrect. In admin/modules/modules.php, the lines with:

       if ($mid == "") {
      sql_query("insert into ".$prefix."_modules 
values (NULL, '$modlist[$i]', '$modlist[$i]', '0', '0', '1')", $dbi);
       }

should have been:

       if ($mid == "") {
           sql_query("insert into ".$prefix."_modules 
values (NULL, '$modlist[$i]', '$modlist[$i]', '0', '0', '1', '0')", $dbi);
       }

Notice the extra

,'0' 

before the

)",$dbi);

This error seems to affect v. 7 alpha and some of the 7.0 FINAL downloads.

You should also be aware that there are some third party modules which alter the nuke_modules table. All you have to do to determine if this might be a problem for you, is to view your nuke_modules table through phpMyAdmin (Section 3.3) or a similar tool, count the number of fields and then compare this number with the code in admin/modules.php:

if ($mid == "") {
      sql_query("insert into ".$prefix."_modules 
values (NULL, '$modlist[$i]', '$modlist[$i]', '0', '0', '1', '0')", $dbi);
}

The above gives us 7 fields.

 

Site Info v2.2.2

Last SeenLast Seen
Server TrafficServer Traffic
  • Total: 337,498,550
  • Today: 35,090
Server InfoServer Info
  • Sep 26, 2017
  • 11:18 am PDT
 
 

Daily Inspiration