Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RavenNuke(tm) v2.5x
Author Message
hicuxunicorniobestbuildpc
Life Cycles Becoming CPU Cycles


Joined: Aug 13, 2009
Posts: 967
Location: Netherland

PostPosted: Tue Nov 11, 2014 9:20 am Reply with quote

If you create new module you must activate it but when u click on the Activate button it will not show on your navigation menu as a default. You must go again and click on Edit again in order to show the module on the nav menu. I wonder if we can do it in 1 step instead of 2 steps.

I think the modification should be in admin/modules/modules.php right?

I will take it a look but if someone knows better to be straight forward to change the code.
 
View user's profile Send private message Visit poster's website
neralex
The Mouse Is Extension Of Arm


Joined: Aug 22, 2007
Posts: 1286
Location: Germany

PostPosted: Tue Nov 11, 2014 12:09 pm Reply with quote

There is no issue like this in the package of RN251.
 
View user's profile Send private message
hicuxunicorniobestbuildpc
PostPosted: Wed Nov 12, 2014 1:12 am Reply with quote

What file I had to update in this package. I replace modules.php from Ravennuke and nothing have been changed to modify this option. Anyone can tell me where I have to look. Neralex. I have Ravennuke 2.51 installed in differents places. I guess you didn't understand my post. I will make a video so people get better understanding.
 
neralex
PostPosted: Wed Nov 12, 2014 4:34 am Reply with quote

Fresh install of RN251 tested with all themes in the package.

• Modules-Administration > AvantGo > Deactivate = module isn't shown in the NukeNAV menue for header and sideblock (block-nukeNAV.php)

• Modules-Administration > AvantGo > Activate = module is shown in the NukeNAV menue for header and sideblock (block-nukeNAV.php)

Works!
 
hicuxunicorniobestbuildpc
PostPosted: Fri Nov 21, 2014 2:15 am Reply with quote

Well! It is not working with me and I am running PHP 5.5.17 last version with Ravennuke 2.51. I made a video today. Sorry for the delay

I hope everybody understand what I am talking about.

 
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6792
Location: Ha Noi, Viet Nam

PostPosted: Wed Dec 17, 2014 1:45 am Reply with quote

Yes I see what you mean. You have to activate the module and then use 'Edit' because by default, the module link is set as "not visible in the menu block".
This isn't a bug, it was designed this way to ensure admins set the correct access permissions, though it can be inconvenient if you are constantly altering access permissions on modules or constantly installing modules.
It isn't something we'll be looking to modify in the future as all our very limited free time is now spent concentrated on RavenCMS.
 
View user's profile Send private message Send e-mail
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RavenNuke(tm) v2.5x

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©