Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> phpnuke 6.8
Author Message
salsaGalaxy
Regular
Regular


Joined: Mar 21, 2004
Posts: 54
Location: Bucharest, Romania

PostPosted: Wed Mar 24, 2004 7:29 am Reply with quote

if i set $gfx_chk =7; will be show the code in site info block?
now the code show everywhere, but not in site info block!
 
View user's profile Send private message Visit poster's website
Nukeum66
Life Cycles Becoming CPU Cycles


Joined: Jul 30, 2003
Posts: 551
Location: Neurotic, State, USA

PostPosted: Wed Mar 24, 2004 7:36 am Reply with quote

Try it

_________________
Scott Johnson MIS Ubuntu/Linux 11.10 
View user's profile Send private message Visit poster's website
Nukeum66
PostPosted: Wed Mar 24, 2004 7:42 am Reply with quote

I see you have it working now!!! ......... Laughing
 
salsaGalaxy
PostPosted: Wed Mar 24, 2004 7:48 am Reply with quote

YES YES GOD thanks boys .....finally ........i have a logical site Smile)
 
salsaGalaxy
PostPosted: Wed Mar 24, 2004 7:54 am Reply with quote

ok let's talk tomorrow ihave to go now
my lawyer needs me for her network
fax doesn't work:))))
 
salsaGalaxy
PostPosted: Thu Aug 05, 2004 7:53 am Reply with quote

sal again same problem
last night i'm installed from raven Who is Where and in modules Game Room and in Member List a table with Last visited and now security code image doesn't show !

GD is ok , image code_bg is ok , no extra lines........

what's the problem ...please help me ....

thanks again!
 
salsaGalaxy
PostPosted: Thu Aug 05, 2004 8:28 am Reply with quote

The problem was solved ...the problem appears when i try to include in module .php this code :
Code:
  /////////////////

include_once('includes/RWH_wiw.inc.php');
/////////////////
for block Who is Where !.....

my modules.php is:
Code:
<?php


/************************************************************************/
/* PHP-NUKE: Advanced Content Management System                         */
/* ============================================                         */
/*                                                                      */
/* Copyright (c) 2002 by Francisco Burzi                                */
/* http://phpnuke.org                                                   */
/*                                                                      */
/* This program is free software. You can redistribute it and/or modify */
/* it under the terms of the GNU General Public License as published by */
/* the Free Software Foundation; either version 2 of the License.       */
/************************************************************************/

require_once("mainfile.php");
$module = 1;

if (isset($name)) {
    global $nukeuser;
    $nukeuser = base64_decode($user);
    $sql = "SELECT active, view FROM ".$prefix."_modules WHERE title='$name'";
    $result = $db->sql_query($sql);
    $row = $db->sql_fetchrow($result);
    $mod_active = $row[active];
    $view = $row[view];
        if (($mod_active == 1) OR ($mod_active == 0 AND is_admin($admin))) {
   if (!isset($mop)) { $mop="modload"; }
   if (!isset($file)) { $file="index"; }
   if (ereg("\.\.",$name) || ereg("\.\.",$file) || ereg("\.\.",$mop)) {
       echo "You are so cool...";
   } else {
       $ThemeSel = get_theme();
       if (file_exists("themes/$ThemeSel/modules/$name/$file.php")) {
      $modpath = "themes/$ThemeSel/";
       } else {
      $modpath = "";
       }
       if ($view == 0) {
      $modpath .= "modules/$name/$file.php";
          if (file_exists($modpath)) {
          include($modpath);
          } else {
          die ("Sorry, such file doesn't exist...");
      }
       }
       if ($view == 1 AND is_user($user) || is_admin($admin)) {
      $modpath .= "modules/$name/$file.php";
          if (file_exists($modpath)) {
          include($modpath);
          } else {
          die ("Sorry, such file doesn't exist...");
      }
       } elseif ($view == 1 AND !is_user($user) || !is_admin($admin)) {
      $pagetitle = "- "._ACCESSDENIED."";
      include("header.php");
      title("$sitename: "._ACCESSDENIED."");
      OpenTable();
      echo "<center><b>"._RESTRICTEDAREA."</b><br><br>"
          .""._MODULEUSERS.""
          .""._GOBACK."";
      CloseTable();
      include("footer.php");
      die();
       }
       if ($view == 2 AND is_admin($admin)) {
      $modpath .= "modules/$name/$file.php";
          if (file_exists($modpath)) {
          include($modpath);
          } else {
          die ("Sorry, such file doesn't exist...");
      }   
       } elseif ($view == 2 AND !is_admin($admin)) {
      $pagetitle = "- "._ACCESSDENIED."";
      include("header.php");
      title("$sitename: "._ACCESSDENIED."");
      OpenTable();
      echo "<center><b>"._RESTRICTEDAREA."</b><br><br>"
          .""._MODULESADMINS.""
          .""._GOBACK."";
      CloseTable();
      include("footer.php");
      die();
       }
   }
    } else {
   include("header.php");
   OpenTable();
   echo "<center>"._MODULENOTACTIVE."<br><br>"
       .""._GOBACK."</center>";
   CloseTable();
   include("footer.php");
    }
} else {
    die ("Sorry, you can't access this file directly...");
}

?>


and Raven where exactly must to put your code ?
after $module?or after $view? or where?

thanks in advanced!
sorry for my english!
 
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17084

PostPosted: Thu Aug 05, 2004 9:21 am Reply with quote

From the README
Quote:
edit modules.php. On or about line 22
[FIND]
$name = trim($name);

[INSERT AFTER]
/////////////////
include_once('includes/RWH_wiw.inc.php');
/////////////////
 
View user's profile Send private message
salsaGalaxy
PostPosted: Thu Aug 05, 2004 5:12 pm Reply with quote

i read the readme ....before i ask you but where $name=trim($name).....my code in modules .php is shown above Sad
 
Raven
PostPosted: Thu Aug 05, 2004 6:14 pm Reply with quote

I see your confusion Confused

It doesn't appear you have installed some patches/fixes. After $module = 1; add this
Code:
$name = trim($name); 

/////////////////
include_once('includes/RWH_wiw.inc.php');
/////////////////
so you will have
Code:
$module = 1;

$name = trim($name);
/////////////////
include_once('includes/RWH_wiw.inc.php');
/////////////////
 
salsaGalaxy
PostPosted: Fri Aug 06, 2004 2:47 am Reply with quote

sorry but doesn't work ..if i include your code
Code:
$module = 1; 

$name = trim($name);
/////////////////
include_once('includes/RWH_wiw.inc.php');
/////////////////


in modules php.....

my security code dissapear...missing ....and i hate this ! Evil or Very Mad

sorry for my language
thanks !
 
Raven
PostPosted: Fri Aug 06, 2004 4:27 am Reply with quote

Make sure that there are no blank lines after the closing ?> in includes/RWH_wiw.inc.php
 
salsaGalaxy
PostPosted: Fri Aug 06, 2004 7:01 am Reply with quote

oooooooops ...yes......blank lines... Bang Head
now work ...thanks raven.....

you are the best! RavensScripts
 
nima_azad
New Member
New Member


Joined: May 26, 2005
Posts: 1

PostPosted: Thu May 26, 2005 6:03 am Reply with quote

Nukeum66 wrote:
Well that's good! Now look in images/admin/ and modules/Your_Account/images and see if this image file is there code_bg


hi , I have the same problem and i checked with gdtest and i have got this message "GD is enable! What now?" and also i have code_gd.jpg files in both directory you mentioned but still i have problem would you please help me to solve it
thanks
 
View user's profile Send private message
Raven
PostPosted: Thu May 26, 2005 6:44 am Reply with quote

Only registered users can see links on this board! Get registered or login!
 
ozbutcher
Worker
Worker


Joined: Jan 17, 2007
Posts: 170

PostPosted: Thu Feb 22, 2007 9:39 am Reply with quote

Hmm I still don't have the security image showing either.

I am using php 5.1.6 and GD 2.0.28. The test file on the first page worked for me.

I had a look in the folders and found there was no image in my \modules\your account so I copied it in there and its already in my images\admin folder. Yet still I get bad link image box showing in stead of the image in IE or I get just text in mozilla "security code" no image.
 
View user's profile Send private message
ozbutcher
PostPosted: Fri Feb 23, 2007 9:52 am Reply with quote

I installed another copy of the ravennuke distro into another folder and the security images worked on that site (http://unt.swisshut.com/test). Don't know why it won't work on my clan site (http://burnt-clan.com).

I copied over the exact same config.php file I used from the testnuke site (changed database field of course) and didnt work. I can only assume something has damaged my nuke.
 
evaders99
Former Moderator in Good Standing


Joined: Apr 30, 2004
Posts: 3221

PostPosted: Fri Feb 23, 2007 9:58 pm Reply with quote

Go to the Image path and put it in your browser. Go to View Source and see if it returns an actual HTML code. That generally means you have some text output before the image is outputted (that being the gibberish code you should see in the source)

_________________
- Only registered users can see links on this board! Get registered or login! -

Need help? Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
ozbutcher
PostPosted: Sat Feb 24, 2007 9:04 am Reply with quote

I'm a little confused but I did this:

- Enabled security images in my config.php (set to 7).
- Loaded mozilla and logged out from my previous auth session.
- Last mouse clicked where the security image should been and selected 'View Image'.
- It displayed a link (www.mysite.com/index.php?gfx=gfx&random_num=17458).
- I last mouse clicked and selected 'view page source'
- A whole bunch of characters came up.

The only thing readable within the jargon was this:
CREATOR: gd-jpeg v1.0 (using IJG JPEG v62), quality = 75

Does this mean something to you evader? Smile
 
evaders99
PostPosted: Sun Feb 25, 2007 8:47 pm Reply with quote

If that is the beginning of the code, it means its generating the image correctly. Perhaps you need to link us to the exact page to show us the problem
 
ozbutcher
PostPosted: Sun Feb 25, 2007 10:10 pm Reply with quote

I can't really leave the show code thingo on because my clan won't be able to log into the website. I've taken some screenies.... and I did notice there is some garbled code before that line displays that I mentioned above... could that maybe be why?

Image
Image
 
Susann
Moderator


Joined: Dec 19, 2004
Posts: 3191
Location: Germany:Moderator German NukeSentinel Support

PostPosted: Mon Feb 26, 2007 3:46 am Reply with quote

Nice picture. However, I believe you just need to find the blank lines before <or after >
in your files. I solved that security code issue in Nuke 6.5 it was only a blank line before. However, you need to check the most of your files (e.g. config, modules, mainfile, your account etc.) with a good editor (possible including language files).
 
View user's profile Send private message
ozbutcher
PostPosted: Mon Feb 26, 2007 4:26 am Reply with quote

okay I'll look through them all and see how I go. thanks.
 
ozbutcher
PostPosted: Mon Feb 26, 2007 4:38 am Reply with quote

That did the trick thanks!! I didnt know such a small error on my part did that Smile

I found the extra line in one of my theme files.

It looks like this solved another problem I had!! My backend rss feeds never worked until just now. I remembered seeing a extra line in the backend php file whilst I was checking.
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> phpnuke 6.8

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©